iDempiere Installation Script Updates

Hi Everyone, The purpose of this post is to update you on recent changes to the iDempiere installation script. Change #1: iDempiere version 6.2 defaults to the Logilite distribution of iDempiere. Here are the reasons for this change: The core

iDempiere Open Source ERP Sustainability

Hi Everyone, The purpose of this post is to answer the common questions: “how is iDempiere free?”, and “how do project members make money from a free project?” Before we get started, here are a couple of quick iDempiere facts

Upgrading iDempiere

Hi Everyone, The purpose of this post is to discuss upgrading iDempiere from one major version to the next. Before we dive into the details, I want to cover some basic principles first. Any time you are upgrading iDempiere, you

iDempiere Installation Script Now Supports iDempiere 7.1

Hi Everyone, The purpose of this post is to announce that my automated iDempiere installation script now supports iDempiere 7.1. Please note that the scripts still installs iDempiere 6.2 (the current stable version) by default. You can install 7.1 using

iDempiere Installation Script Now Supports iDempiere 6.2

Hi Everyone, The purpose of this post is to announce that my automated iDempiere installation script now supports iDempiere 6.2. I realize the timing on this announcement is a little funny since iDempiere 7.1 just released; however, there were significant

Connect to an AWS Internal Resource via SSH from an External Interface – PostgreSQL and RDP

Hi Everyone, You will often restrict access to an AWS VPC (network) from the outside world. The default and probably most common way to gain access to this secure network is via SSH. The purpose of this post is to

iDempiere Plugin Development – Database Queries Made Easy

  Hi Everyone, The purpose of this post is to review database query best practices for iDempiere customization/plugin development. The core iDempiere developers do a great job of keeping iDempiere fast as stable. When you start customizing iDempiere with plugins,

iDempiere Installation Script Now Supports iDempiere 4.1

Hi Everyone, The purpose of this post is to announce that my automated iDempiere installation script now supports iDempiere 4.1 by default. Details: You can still install iDempiere 3.1 using the section named: Install from a different jenkins server (-J name

iDempiere Installation Script Now Supports Ubuntu 16.04LTS

Hi Everyone, The purpose of this post is to announce that my automated iDempiere installation script now supports Ubuntu 16.04LTS. Installation Descriptions iDempiere Server installation on Ubuntu 16.04LTS iDempiere Development Environment Automated Installation